Some customers are experiencing delays in vessel data

Incident Report for Kognifai Maritime Ecosystem

Resolved

This incident has been resolved.
Posted Jun 25, 2026 - 07:09 UTC

Investigating

We are experiencing delayed data for many vessels at the moment. All data is queued up on the vessel, and no data is lost.
We are investigating the issue.
Posted Jun 25, 2026 - 05:34 UTC
This incident affected: My Vessels and Applications (Vessel Performance Merchant).