My Vessels: Slow response

Incident Report for Kognifai Maritime Ecosystem

Resolved

This incident has been resolved.
Posted Oct 09, 2025 - 10:34 UTC

Identified

We have reverted the "My Vessels" feature, which has improved loading times. We are still in the process of verification.
Posted Oct 09, 2025 - 08:37 UTC

Investigating

Some customers may encounter slower response times when loading applications.
Posted Oct 09, 2025 - 08:05 UTC
This incident affected: My Vessels.