The team has identified the root cause and implemented the fix. We are currently monitoring the situation closely to ensure everything is functioning correctly.
Posted Dec 28, 2025 - 11:31 UTC
Investigating
We have encountered another issue, which is currently under active investigation by the team.
Posted Dec 24, 2025 - 07:03 UTC
Monitoring
The team has identified the root cause and implemented the fix. We will monitor the situation closely for an extended period to ensure everything is functioning correctly.
Posted Dec 23, 2025 - 13:45 UTC
Update
We are continuing to investigate this issue.
Posted Dec 23, 2025 - 08:03 UTC
Investigating
We are currently investigating this issue.
Posted Dec 23, 2025 - 08:00 UTC
Monitoring
We have identified the issue, and the team is monitoring it. There are still delays for some time.
Posted Dec 22, 2025 - 12:46 UTC
Update
We are continuing to investigate this issue.
Posted Dec 22, 2025 - 08:14 UTC
Investigating
Some customers may experience delays in data uploads. We're actively investigating the issue and will resolve it as quickly as possible.
Posted Dec 22, 2025 - 08:00 UTC
This incident affected: Data Services (Timeseries API), My Vessels, and Applications (Data Explorer, Vessel Performance Merchant).